How do I fix caption language mismatches in Kaltura videos from Zoom recordings?

Summary

Videos imported into Kaltura from Zoom Cloud Recordings may have captions in a different language due to meeting participants changing the captioning language. To prevent this, enable "Lock Caption Language for this meeting" in Zoom and to fix existing recordings, order new captions in Kaltura and delete the incorrect ZOOM_CC captions.

Body

Quick Links: | Environment | Solution | Root Cause |

In Kaltura, videos imported from Zoom Cloud Recordings might display closed captions in a language different from the speaker's. This happens when a meeting participant changes the captioning language during the meeting. The altered language setting affects the default captions in Kaltura, leading to a mismatch between the spoken language and the captions displayed. This issue impacts the clarity and accessibility of the video content for viewers.

Environment

  • Videos imported to Kaltura from Zoom Cloud Recordings.
  • Meetings where participants have access to change the caption language.

Solution

To prevent and fix caption language mismatches in Kaltura videos created from Zoom Cloud Recordings, follow these steps:

Preventing Caption Language Mismatch

To ensure your Zoom recordings transfer to Kaltura with the correct captions, do the following:

  1. In a Zoom meeting, select the Show Captions option menu [1].
  2. Choose Host Caption Control Settings [2].
  3. Enable Lock Caption Language for this meeting [3] to ensure the caption language stays consistent with the speaker's language throughout the meeting.
  4. Ensure the Caption Language is set to the correct language (e.g., English) [4].

Zoom in-meeting caption settings.

Fixing an Existing Recording

If a Zoom recording already exists with captions in the incorrect language:

  1. Go to My Media from Kaltura or Canvas.
  2. Open the video with the incorrect captions.
  3. Select Actions [1] > Caption + Enrich [2] > Order Captions & Enrichment Services [3].
  4. Select the appropriate captioning language.
  5. Select Submit to generate corrected captions [4]. This process can take a while, depending on the length of the video.

Ordering automatic captions on a Zoom recording in Kaltura.

Deleting Incorrect Captions

To remove the existing, incorrect captions on one of your Zoom recordings, do the following:

  1. Edit the video in question.
  2. Navigate to the Captions section [1].
  3. Find the ZOOM_CC caption file [2].
  4. Select the Delete button [3] next to the ZOOM_CC captions to delete them.

Ensure that you have submitted a request for the correct captions before deleting the incorrect ones to avoid having videos without any captions.

Deleting the Zoom_CC captions from Kaltura.

Root Cause

When a Zoom meeting participant changes the captioning language, this preference affects the default caption language in the resulting Kaltura video. Zoom's default settings allow participants to select caption languages, which can be different from the meeting's primary language. If the "Lock Caption Language for this meeting" setting is not enabled, each participant can alter the caption language, leading to inconsistencies in the recorded content once it is imported into Kaltura.

Details

Details

Article ID: 113728
Created
Tue 2/20/24 7:41 PM
Modified
Tue 7/2/24 1:34 PM